SteamOS Troubleshooting – No Audio With HDMI or On Board

Thanks to a great fellow over at GitHub, I recently resolved some sound issues with SteamOS after I swapped graphics car.  Maybe these steps will help you as well.  This will be linked to the main SteamOS workarounds launch page.

Caution:  Please try this method at your own risk.  If you wish to be safe about this backup the pulse folders before removing them.  All steps below should be reversible.  If you remove the file configured below, restore the pulse folders.  and regenerate your initramfs, you should be back to the state you were in.  I have tested this for onboard Intel audio, as well as AMD/Nvidia HDMI output.  You may find the easiest method to be using Ye Olde SteamOSe, detailed at the bottom of this article.

Possible Fix 1: Adding snd-hda-intel

First, enter the desktop mode by exiting steam after enabled it under settings.

Set your password and login as root:

passwd
sudo su

Now, check out alsa’s configuration to ensure your card shows:

cat /proc/asound/cards
lspci | grep Audio
cat /proc/asound/cardX

If all looks good, take a look at modprobe’s contents:

cd /etc/modprobe.d/
ls -la

Next, fix the missing entry and Pulse Audio by creating the following file “sna-hda-intel.conf” under /etc/modprobe.d/”

options snd-hda-intel probe_mask=0xa, -1

Once you save and exit your file, remove the existing broken Pulse Audio configs for both users:

rm -rf /home/steam/.pulse
rm -rf /home/desktop/.pulse

Finally, rebuild the initial RAM file system and reboot:

update-initramfs -u
reboot

Hopefully after the reboot you can now use your audio via HDMI or your onboard sound output.  It worked for me, so hope it does for you.

Possible Fix 2: Configuring alsamixer

Another option some have tried, and been successful with, is checking alsamixer, the common soundsystem used on most Linux distributions.  It is suggested you add the Debian Wheezy repositories for adding the ALSA utilities:

sudo nano /etc/apt/sources.list

Add the following lines:


deb ftp://mirror.nl.leaseweb.net/debian/ wheezy main contrib non-free
deb-src ftp://mirror.nl.leaseweb.net/debian/ wheezy main contrib non-free

Make sure no SteamOS packages get replaced by the updater by creating a preferences file with the following command:

 sudo nano /etc/apt/preferences

Copy these lines to the file:


Package: *
Pin: release l=SteamOS
Pin-Priority: 900

Package: *
Pin: release l=Debian
Pin-Priority:-10

Once these lines are added, save the file with CTRL+O, ENTER, then CTRL+X to exit the file.  Now, install alsa-utils with:

apt-get update
apt-get install -t wheezy alsa-utils

Screenshot from 2014-01-11 10:24:56

Once the package is installed, enter ‘alsamixer’ on the Terminal CLI, and make sure any applicable channels for you HDMI interface or onboard are not muted with “MM” as a label.  Use the keyboard key “m” to mute/unmute a channel

Possible Fix 3: Trying Different Audio Masks

Some users have also reported sound coming through HDMI or onboard by trying different masks:

options snd-hda-intel probe_mask=0x101
options snd-hda-intel probe_mask=0x102
options snd-hda-intel probe_mask=0x104
options snd-hda-intel probe_mask=0x108

Do not forget to update your initramfs with:

sudo update-initramfs -u
sudo reboot

This may help you, I am still looking into nailing down the right masks for cards.

If all else fails

There are several possible fixes located on this github post.  I have not yet evaluated these posts, but when I do I may add them to this page.  A simple reboot is always a good idea as well. You may also find some saving grace in some Linux bloggers/users anecdotal experiences and stories about the matter.  Of course, use caution with whichever you may find and always backup critical data first.

The easiest way I have seen audio network and wireless setup by default is by using Ye Olde SteamOSe, made by directhex.  I, as well as many Linux users, gamers, and folk alike, owe a lot of thanks to the work he is doing.   In the end, if you choose to stick with the plain jane SteamOS installer set, be reminded SteamOS is still a Beta!  Many folks, albeit understandably frustrated, are writing off SteamOS due to small quirks.  It can be argued that these should not exist, but with many Linux projects, things take time, no matter how small or big a project or developer base can be.

-mikeyd

Advertisements

About professorkaos64

www.libregeek.org

Posted on 20131227, in Fix This!, Games, Games for Linux, How-To and tagged , , , , , , . Bookmark the permalink. 4 Comments.

  1. SadSilentSteam

    Completely broke my audio to an even worst state. Now I can’t follow other methods of getting it to work.

    • professorkaos64

      Worked just fine for me. Did you follow it to the end? Double check you filename, contents, and re do the last set of sets to generate the image. This worked for almost everyone I have seen have trouble with HDMI audio. I did have to raise my volume afterwards as well. You could peer into alsamixer for a look too. I don’t believe what you have is “unrecoverable ” I can do my beat to help you.

      Please, after rechecking the work above, let me know your sound card with “lspci -v | less” as well as if you are trying HDMI out or Onboard audio. I will do my best to try and help you out. Valve wasn’t lying when they slapped the beta on this.

      If in the end you still have no audio, and get to a very frustrating point, I would definitely try Ye Olde SteamOSe (http://directhex.github.io/steamos-installer/) They have “beefed up” the standard SteamOS installer to include packages that should have been in there in the first place. If that fails, I would just load Ubuntu LTS or 13.04 (several games reccomend 13.04 now under sys requirements) and set Steam to start in big picture mode, as well as start Steam when your system starts. You won’t be missing much for now, that is until special things start showing up in SteamOS, such as possible DRM services.

  1. Pingback: How To – Workarounds for SteamOS beta System Requirements | The Linux Cauldron

  2. Pingback: SteamOS – Changing the Default Audio Device | The Linux Cauldron

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s